Library / Sysinternals

accesschk.exe

Reports effective permissions for securable objects · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 3

OriginalFilename

  • accesschk.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as accesschk64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\accesschk.exe'
    - OriginalFileName: 'accesschk.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
accesschk.exe1x866.15.0.0Sysinternals✓ 1

InternalName: Accesschk · Product: Sysinternals AccessChk

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
69bd46e5dba2…6.15.0.0x86accesschk.exeSysinternals AccessChkSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.