Library / LOLBin

advpack.dll

ADVPACK · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • ADVPACK.DLL

Shared with other binaries

Gotchas

  • Same OriginalFilename as ieadvpack.dll, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\advpack.dll'
    - OriginalFileName: 'ADVPACK.DLL'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ADVPACK.DLL30x64, x8611.0.10240.16384 → 11.0.28000.2179Win10 1507 → Win11 26H1 (20)Winbindex

InternalName: ADVPACK.DLL · Product: Internet Explorer

All 30 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8b13afa5a876…11.0.28000.2179x86ADVPACK.DLLWin11 26H1UnsignedWinbindex
80e40a9e5b0d…11.0.28000.1896x64ADVPACK.DLLWin11 26H1Winbindex
4953bb9817a1…11.0.26100.8328x86ADVPACK.DLLWin11 24H2UnsignedWinbindex
d393b07fb4b8…11.0.26100.8115x64ADVPACK.DLLWin11 24H2UnsignedWinbindex
d0f18226eda1…11.0.22621.3527x64ADVPACK.DLLWin11 22H2, Win11 23H2UnsignedWinbindex
4cc0fe1d2e54…11.0.22621.3527x86ADVPACK.DLLWin11 22H2, Win11 23H2UnsignedWinbindex
634ca0884082…11.0.19041.4355x86ADVPACK.DLLWin10 21H2, Win10 22H2UnsignedWinbindex
3c9abfd8ba10…11.0.19041.4355x64ADVPACK.DLLWin10 21H2, Win10 22H2UnsignedWinbindex
d91af176c416…11.0.26100.1150x64ADVPACK.DLLWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
5810d72a6fc8…11.0.26100.1x86ADVPACK.DLLWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
c47b998d329b…11.0.22000.2600x86ADVPACK.DLLWin11 21H2UnsignedWinbindex
0eabdb6641ba…11.0.22000.2600x64ADVPACK.DLLWin11 21H2UnsignedWinbindex
a8bd79d517ce…11.0.19041.1x86ADVPACK.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
65de1e0484a3…11.0.19041.1x64ADVPACK.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
f3453cb9de64…11.0.18362.1x86ADVPACK.DLLWin10 1903, Win10 1909Signed (Catalog file)Winbindex
b8904d03ed56…11.0.18362.1x64ADVPACK.DLLWin10 1903, Win10 1909Signed (Catalog file)Winbindex
465e48ebb0ac…11.0.17763.1x86ADVPACK.DLLWin10 1809UnsignedWinbindex
0e182fb74701…11.0.17763.1x64ADVPACK.DLLWin10 1809UnsignedWinbindex
fe9edd503cfd…11.0.17134.1x64ADVPACK.DLLWin10 1803UnsignedWinbindex
8ebd4f91c203…11.0.17134.1x86ADVPACK.DLLWin10 1803UnsignedWinbindex
de19ee110839…11.0.15063.994x64ADVPACK.DLLWin10 1703UnsignedWinbindex
39a87334309a…11.0.15063.0x86ADVPACK.DLLWin10 1703UnsignedWinbindex
f50b65ab36a0…11.0.16299.15x64ADVPACK.DLLWin10 1709UnsignedWinbindex
224415d36547…11.0.16299.15x86ADVPACK.DLLWin10 1709UnsignedWinbindex
df3c85030c04…11.0.14393.0x86ADVPACK.DLLWin10 1607UnsignedWinbindex
84a1a2db28a1…11.0.14393.0x64ADVPACK.DLLWin10 1607UnsignedWinbindex
b2c7248c65b5…11.0.10586.0x64ADVPACK.DLLWin10 1511UnsignedWinbindex
34222b54ee78…11.0.10586.0x86ADVPACK.DLLWin10 1511UnsignedWinbindex
f20254846e9d…11.0.10240.16384x86ADVPACK.DLLWin10 1507UnsignedWinbindex
d7eb6c5812ad…11.0.10240.16384x64ADVPACK.DLLWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.