Library / Windows

agentservice.exe

AgentService EXE · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • AgentService.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\agentservice.exe'
    - OriginalFileName: 'AgentService.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
AgentService.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: AgentService EXE · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
572b14cca45b…10.0.26100.9278x64AgentService.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.