Library / Windows

appidcertstorecheck.exe

AppID Certificate Store Verification Task · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • AppIDCertstoreCheck.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\appidcertstorecheck.exe'
    - OriginalFileName: 'AppIDCertstoreCheck.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
AppIDCertstoreCheck.exe1x6410.0.26100.8457Host scan✓ 1

InternalName: AppIDCertstoreCheck.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
513605bce4c1…10.0.26100.8457x64AppIDCertstoreCheck.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.