Library / Windows

appvdllsurrogate.exe

Client DLL Surrogate Host · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • AppVDllSurrogate.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\appvdllsurrogate.exe'
    - OriginalFileName: 'AppVDllSurrogate.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
AppVDllSurrogate.exe2x64, x8610.0.26100.8972Host scan✓ 2

InternalName: AppVDllSurrogate.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6c430b80b9ca…10.0.26100.8972x64AppVDllSurrogate.exeHost scan✓
6c2c150fb2f5…10.0.26100.8972x86AppVDllSurrogate.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.