Library / Windows

arp.exe

TCP/IP Arp Command · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 3

OriginalFilename

  • arp.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\arp.exe'
    - OriginalFileName: 'arp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
arp.exe11x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: arp.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2668f8a0d4aa…10.0.28000.2804x64arp.exeWin11 26H1UnsignedWinbindex
998129917f08…10.0.28000.1x86arp.exeWin11 26H1UnsignedWinbindex
7417347d0f21…10.0.26100.9549x64arp.exeWin11 24H2UnsignedHost scan, Winbindex✓
6b3fe599379a…10.0.26100.2161x86arp.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
cca1f962f943…10.0.14393.0x64arp.exeWin10 1607UnsignedWinbindex
c1a71bbb60fa…10.0.14393.0x86arp.exeWin10 1607UnsignedWinbindex
a1c6fed72b64…10.0.26100.2161x64arp.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
9264c1a786e7…10.0.10586.0x64arp.exeWin10 1511UnsignedWinbindex
1c324f1a600e…10.0.10586.0x86arp.exeWin10 1511UnsignedWinbindex
e9f6d4c9804a…10.0.10240.16384x64arp.exeWin10 1507UnsignedWinbindex
02970bf69bcb…10.0.10240.16384x86arp.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.