Library / LOLBin

aspnet_compiler.exe

aspnet_compiler.exe · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 4

OriginalFilename

  • aspnet_compiler.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\aspnet_compiler.exe'
    - OriginalFileName: 'aspnet_compiler.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
aspnet_compiler.exe26x64, x864.6.79.0 → 4.8.10001.0Win10 1507 → Win11 25H2 (19)Host scan, Winbindex✓ 2

InternalName: aspnet_compiler.exe · Product: Microsoft® .NET Framework

All 26 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bcb6a8883c60…4.8.9221.0x64aspnet_compiler.exeWin11 25H2Signed (Overlay)Winbindex
7c8156c97947…4.8.9221.0x86aspnet_compiler.exeWin11 25H2Signed (Overlay)Winbindex
f1e26456ea61…4.8.9032.0x64aspnet_compiler.exeWin11 22H2 … Win11 24H2 (3)Signed (Overlay)Winbindex
923c541ce782…4.8.9032.0x86aspnet_compiler.exeWin11 22H2 … Win11 24H2 (3)Signed (Overlay)Winbindex
9ed0aa0a40c8…4.8.4084.0x64aspnet_compiler.exeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
99a2c778c9a6…4.8.4084.0x86aspnet_compiler.exeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
ed0d718e3017…4.8.4161.0x86aspnet_compiler.exeWin11 21H2Signed (Overlay)Winbindex
39bb2299b678…4.8.4161.0x64aspnet_compiler.exeWin11 21H2Signed (Overlay)Winbindex
cd02eab0b4e0…4.8.3752.0x64aspnet_compiler.exeWin10 1903, Win10 1909Signed (Overlay)Winbindex
50b963f0aa98…4.8.3752.0x86aspnet_compiler.exeWin10 1903, Win10 1909Signed (Overlay)Winbindex
d3351484c40b…4.7.3190.0x86aspnet_compiler.exeWin10 1809Signed (Overlay)Winbindex
76070e6debb3…4.7.3190.0x64aspnet_compiler.exeWin10 1809Signed (Overlay)Winbindex
a1661db1b74b…4.7.3056.0x86aspnet_compiler.exeWin10 1803Signed (Overlay)Winbindex
7a2c15ce0e85…4.7.3056.0x64aspnet_compiler.exeWin10 1803Signed (Overlay)Winbindex
856d147dc468…4.7.2556.0x64aspnet_compiler.exeWin10 1709Signed (Overlay)Winbindex
1e6aa51b4291…4.7.2556.0x86aspnet_compiler.exeWin10 1709Signed (Overlay)Winbindex
c365d8e7bc2a…4.7.2046.0x64aspnet_compiler.exeWin10 1703Signed (Overlay)Winbindex
59ea3bb48a5d…4.7.2046.0x86aspnet_compiler.exeWin10 1703Signed (Overlay)Winbindex
1a6715f49eac…4.6.1586.0x64aspnet_compiler.exeWin10 1607Signed (Overlay)Winbindex
19c0f7bcdaa2…4.6.1586.0x86aspnet_compiler.exeWin10 1607Signed (Overlay)Winbindex
a92f1ef8caef…4.6.1038.0x86aspnet_compiler.exeWin10 1511Signed (Overlay)Winbindex
35ca360165dc…4.6.1038.0x64aspnet_compiler.exeWin10 1511Signed (Overlay)Winbindex
97c5b1737e1b…4.6.79.0x64aspnet_compiler.exeWin10 1507Signed (Overlay)Winbindex
1ad572bbfe57…4.6.79.0x86aspnet_compiler.exeWin10 1507Signed (Overlay)Winbindex
c7d3e78110a0…4.8.10001.0x86aspnet_compiler.exeHost scan✓
c6da35a210e0…4.8.10001.0x64aspnet_compiler.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.