Library / Windows

autochk.exe

Auto Check Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • AutoChk.Exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\autochk.exe'
    - OriginalFileName: 'AutoChk.Exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
AutoChk.Exe2x64, x8610.0.26100.9444Host scan✓ 2

InternalName: AutoChk · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8f20434370ed…10.0.26100.9444x64AutoChk.ExeHost scan✓
2821a85a8cae…10.0.26100.9444x86AutoChk.ExeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.