Library / Windows

baaupdate.exe

BitLocker Access Agent Update Utility · Microsoft Corporation

WindowsParsedSigma refs: 2

OriginalFilename

  • BAAUPDATE.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\baaupdate.exe'
    - OriginalFileName: 'BAAUPDATE.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BAAUPDATE.EXE3x6410.0.10240.16384 → 10.0.14393.206Win10 1507 → Win10 1607 (3)Winbindex

InternalName: BAAUPDATE · Product: Microsoft® Windows® Operating System

All 3 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0e0f8e2f774c…10.0.14393.206x64BAAUPDATE.EXEWin10 1607UnsignedWinbindex
f246602378b9…10.0.10586.0x64BAAUPDATE.EXEWin10 1511UnsignedWinbindex
8ba1af78b2e8…10.0.10240.16384x64BAAUPDATE.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.