Library / LOLBin

bash.exe

Microsoft Bash Launcher · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 20

OriginalFilename

  • Bash.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bash.exe'
    - OriginalFileName: 'Bash.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Bash.exe1x6410.0.26100.9278Host scan

InternalName: Bash.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds · 15 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
03da25ca4f06…10.0.26100.9278x64Bash.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.