Library / Windows

bdeuisrv.exe

BDE UI Launcher · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • BDEUISRV.DLL

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (BDEUISRV.DLL), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: bdeuisrv.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bdeuisrv.exe'
    - OriginalFileName: 'BDEUISRV.DLL'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BDEUISRV.DLL1x6410.0.26100.9711Host scan✓ 1

InternalName: BDEUISRV.DLL · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
7e32ada3350c…10.0.26100.9711x64BDEUISRV.DLLHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.