Library / Windows

bfsvc.exe

Boot File Servicing Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • bfsvc.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as ucsvc.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bfsvc.exe'
    - OriginalFileName: 'bfsvc.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
bfsvc.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: bfsvc.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
7071276b963c…10.0.26100.9711x64bfsvc.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.