Library / LOLBin

bginfo.exe

BGInfo - Wallpaper text configurator · Sysinternals - www.sysinternals.com

LOLBinSysinternalsSysmon-confirmedLOLBASSigma refs: 3

OriginalFilename

  • BGInfo.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as bginfo64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bginfo.exe'
    - OriginalFileName: 'BGInfo.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BGInfo.exe1x864.34.0.0Sysinternals✓ 1

InternalName: BGInfo · Product: BGInfo

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
995e42751d66…4.34.0.0x86BGInfo.exeBGInfoSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.