Library / Sysinternals

bginfo64.exe

BGInfo - Wallpaper text configurator · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 3

OriginalFilename

  • BGInfo.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: bginfo64.exe never fires.
  • Same OriginalFilename as bginfo.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bginfo64.exe'
    - OriginalFileName: 'BGInfo.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BGInfo.exe1x644.34.0.0Sysinternals✓ 1

InternalName: BGInfo · Product: BGInfo

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1d00da4ecb04…4.34.0.0x64BGInfo.exeBGInfoSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.