Library / Windows

bthudtask.exe

Bluetooth Uninstall Device Task · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • BthUdTask.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bthudtask.exe'
    - OriginalFileName: 'BthUdTask.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BthUdTask.exe2x64, x8610.0.26100.7920Host scan✓ 2

InternalName: BthUdTask · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d198bb10ac0c…10.0.26100.7920x86BthUdTask.exeHost scan✓
73a5b2c12f24…10.0.26100.7920x64BthUdTask.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.