Library / Windows

bytecodegenerator.exe

AppX Deployment Bytecode Generator EXE · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • BytecodeGenerator.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\bytecodegenerator.exe'
    - OriginalFileName: 'BytecodeGenerator.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
BytecodeGenerator.exe2x64, x8610.0.26100.8972 → 10.0.26100.9278Host scan✓ 2

InternalName: BytecodeGenerator.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0d9a893bd97b…10.0.26100.9278x64BytecodeGenerator.exeHost scan✓
b34a02286490…10.0.26100.8972x86BytecodeGenerator.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.