Library / Windows

certenrollctrl.exe

Certificate Enrollment Control · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • EnrollComServer.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: certenrollctrl.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\certenrollctrl.exe'
    - OriginalFileName: 'EnrollComServer.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
EnrollComServer.exe2x64, x8610.0.26100.9711Host scan✓ 2

InternalName: EnrollComServer.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c0fb58c60e96…10.0.26100.9711x64EnrollComServer.exeHost scan✓
73941a359f01…10.0.26100.9711x86EnrollComServer.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.