Library / LOLBin

certutil.exe

CertUtil.exe · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 31

OriginalFilename

  • CertUtil.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\certutil.exe'
    - OriginalFileName: 'CertUtil.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CertUtil.exe25x64, x8610.0.10240.20708 → 10.0.28000.3231Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 2

InternalName: CertUtil.exe · Product: Microsoft® Windows® Operating System

All 25 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ffc92062f1b8…10.0.28000.3231x86CertUtil.exeWin11 26H1UnsignedWinbindex
1ce54b2382db…10.0.28000.3086x64CertUtil.exeWin11 26H1UnsignedWinbindex
4b9a2b387614…10.0.26100.9549x86CertUtil.exeWin11 24H2UnsignedHost scan, Winbindex✓
16d0e3543975…10.0.26100.9549x64CertUtil.exeWin11 24H2UnsignedHost scan, Winbindex✓
78b46729dc86…10.0.19041.7802x64CertUtil.exeWin10 21H2UnsignedWinbindex
71bd529126d9…10.0.19041.7802x86CertUtil.exeWin10 21H2UnsignedWinbindex
76dcb34bc788…10.0.17763.9376x86CertUtil.exeWin10 1809UnsignedWinbindex
98adea8ed098…10.0.14393.9611x64CertUtil.exeWin10 1607UnsignedWinbindex
89fc17e411fc…10.0.14393.9611x86CertUtil.exeWin10 1607UnsignedWinbindex
6630aa08681a…10.0.17763.9121x64CertUtil.exeWin10 1809UnsignedWinbindex
f7289fbf9af5…10.0.10240.20708x64CertUtil.exeWin10 1507UnsignedWinbindex
c603a43983df…10.0.10240.20708x86CertUtil.exeWin10 1507UnsignedWinbindex
ebc1d6fe958f…10.0.26100.5074x64CertUtil.exeWin11 24H2, Win11 25H2UnsignedWinbindex
151b2b7e34d2…10.0.26100.5074x86CertUtil.exeWin11 24H2, Win11 25H2UnsignedWinbindex
6af299712fe2…10.0.22621.1992x64CertUtil.exeWin11 22H2, Win11 23H2Signed (Catalog file)Winbindex
16fe23a142fe…10.0.22000.653x64CertUtil.exeWin11 21H2UnsignedWinbindex
44d75cedb201…10.0.22000.434x86CertUtil.exeWin11 21H2UnsignedWinbindex
ebf75f835cb0…10.0.19041.2075x86CertUtil.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
22d1471ed17c…10.0.19041.2075x64CertUtil.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
c8b3a3fb1024…10.0.17134.1967x64CertUtil.exeWin10 1803UnsignedWinbindex
643cd8fac7e4…10.0.17134.1967x86CertUtil.exeWin10 1803UnsignedWinbindex
ce927ceb4cb2…10.0.15063.2614x86CertUtil.exeWin10 1703UnsignedWinbindex
ce7d405d2471…10.0.10586.1106x64CertUtil.exeWin10 1511UnsignedWinbindex
8bf7c45abc99…10.0.10586.1106x86CertUtil.exeWin10 1511UnsignedWinbindex
c3371d31fd25…10.0.15063.447x64CertUtil.exeWin10 1703UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.