Library / Windows

chgport.exe

Change port Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • chgport.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\chgport.exe'
    - OriginalFileName: 'chgport.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
chgport.exe1x6410.0.26100.7623Host scan✓ 1

InternalName: chgport · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2d1bb9ad1636…10.0.26100.7623x64chgport.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.