Library / Windows

chkntfs.exe

NTFS Volume Maintenance Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • CHKNTFS.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\chkntfs.exe'
    - OriginalFileName: 'CHKNTFS.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CHKNTFS.EXE2x64, x8610.0.26100.1Host scan✓ 2

InternalName: chkntfs · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
daeee58bb05b…10.0.26100.1x86CHKNTFS.EXEHost scan✓
c571f4867a2a…10.0.26100.1x64CHKNTFS.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.