Library / Windows

choice.exe

Offers the user a choice · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • choice.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\choice.exe'
    - OriginalFileName: 'choice.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
choice.exe10x64, x8610.0.10240.16384 → 10.0.26100.1Win10 1507 → Win11 25H2 (6)Host scan, Winbindex✓ 2

InternalName: choice.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f0ae8be77fa2…10.0.26100.1x64choice.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
6b86f22d00f1…10.0.26100.1x86choice.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
f11a3916e2a4…10.0.16299.15x86choice.exeWin10 1709UnsignedWinbindex
5c9d93dad910…10.0.16299.15x64choice.exeWin10 1709UnsignedWinbindex
df8085fb7d97…10.0.14393.0x64choice.exeWin10 1607UnsignedWinbindex
dbf371b359e2…10.0.14393.0x86choice.exeWin10 1607UnsignedWinbindex
c50d57fafbc8…10.0.10586.0x86choice.exeWin10 1511UnsignedWinbindex
5209abe8871c…10.0.10586.0x64choice.exeWin10 1511UnsignedWinbindex
e02fd2f66b2a…10.0.10240.16384x86choice.exeWin10 1507UnsignedWinbindex
1edeadafe9d9…10.0.10240.16384x64choice.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.