Library / LOLBin

cipher.exe

File Encryption Utility · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • CIPHER.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\cipher.exe'
    - OriginalFileName: 'CIPHER.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CIPHER.EXE12x64, x8610.0.10240.16384 → 10.0.26100.1150Win10 1507 → Win11 25H2 (7)Host scan, Winbindex✓ 2

InternalName: cipher · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 25 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
07c1f3b3ddc1…10.0.26100.1150x64CIPHER.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
bc9f6e92e1fa…10.0.26100.1x86CIPHER.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
05102da77081…10.0.26100.1x64CIPHER.EXEWin11 24H2UnsignedWinbindex
eb879cd7a1e6…10.0.15063.674x86CIPHER.EXEWin10 1703UnsignedWinbindex
1cc8f9efcc30…10.0.15063.674x64CIPHER.EXEWin10 1703UnsignedWinbindex
d36fa36b52b8…10.0.16299.15x64CIPHER.EXEWin10 1709UnsignedWinbindex
f2c1d0936204…10.0.14393.0x64CIPHER.EXEWin10 1607UnsignedWinbindex
5bffc65b70c4…10.0.14393.0x86CIPHER.EXEWin10 1607UnsignedWinbindex
0e21529b15ab…10.0.10586.0x86CIPHER.EXEWin10 1511UnsignedWinbindex
03f0b909ce2f…10.0.10586.0x64CIPHER.EXEWin10 1511UnsignedWinbindex
d3dcb6b7c059…10.0.10240.16384x86CIPHER.EXEWin10 1507UnsignedWinbindex
465719f1cb83…10.0.10240.16384x64CIPHER.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.