Library / Sysinternals

clockres.exe

Clock resolution display utility · Sysinternals

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Clockres

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: clockres.exe never fires.
  • Same OriginalFilename as clockres64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\clockres.exe'
    - OriginalFileName: 'Clockres'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Clockres1x862.1.0.0Sysinternals✓ 1

InternalName: Clockres · Product: Sysinternals Clockres

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4db4539c62f4…2.1.0.0x86ClockresSysinternals ClockresSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.