Library / LOLBin

cmdl32.exe

Microsoft Connection Manager Auto-Download · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • CMDL32.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\cmdl32.exe'
    - OriginalFileName: 'CMDL32.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CMDL32.EXE14x64, x867.2.10240.17146 → 7.2.28000.1896Win10 1507 → Win11 26H1 (9)Host scan, Winbindex✓ 2

InternalName: CMDL32 · Product: Microsoft(R) Connection Manager

All 14 parsed builds · 24 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
85c344b1610c…7.2.28000.1896x64CMDL32.EXEWin11 26H1UnsignedWinbindex
1729fee275bc…7.2.28000.1896x86CMDL32.EXEWin11 26H1UnsignedWinbindex
d9b225ba8c7b…7.2.26100.1150x64CMDL32.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
12752c9314ab…7.2.26100.1x86CMDL32.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
de3435af48fc…7.2.14393.0x86CMDL32.EXEWin10 1607UnsignedWinbindex
9489cb8520a6…7.2.14393.0x64CMDL32.EXEWin10 1607UnsignedWinbindex
c8815316c65e…7.2.10240.17146x64CMDL32.EXEWin10 1507UnsignedWinbindex
196ab88074c4…7.2.10240.17146x86CMDL32.EXEWin10 1507UnsignedWinbindex
b12f21e80553…7.2.17763.1x64CMDL32.EXEWin10 1809UnsignedWinbindex
5f067f86ad0f…7.2.17763.1x86CMDL32.EXEWin10 1809UnsignedWinbindex
395e7a8356d4…7.2.17134.1967x86CMDL32.EXEWin10 1803UnsignedWinbindex
691420d2a1eb…7.2.15063.0x64CMDL32.EXEWin10 1703UnsignedWinbindex
e6eb1012a8b4…7.2.10586.0x86CMDL32.EXEWin10 1511UnsignedWinbindex
13b9d19816bc…7.2.10586.0x64CMDL32.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.