Library / LOLBin

conhost.exe

Console Window Host · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 13

OriginalFilename

  • CONHOST.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\conhost.exe'
    - OriginalFileName: 'CONHOST.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CONHOST.EXE13x6410.0.10240.16384 → 10.0.28000.2952Win10 1507 → Win11 26H1 (13)Host scan, Winbindex✓ 1

InternalName: ConHost · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 7 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2687424ba35d…10.0.28000.2952x64CONHOST.EXEWin11 26H1UnsignedWinbindex
c86146188b78…10.0.26100.9549x64CONHOST.EXEWin11 24H2UnsignedHost scan, Winbindex✓
5bb5ac50aafb…10.0.19041.7548x64CONHOST.EXEWin10 21H2UnsignedWinbindex
b02ee54fb2ec…10.0.19041.5198x64CONHOST.EXEWin10 21H2, Win10 22H2UnsignedWinbindex
ac68880b0983…10.0.17763.4840x64CONHOST.EXEWin10 1809UnsignedWinbindex
29e4840bf10b…10.0.26100.5074x64CONHOST.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
28daaac4be1f…10.0.22000.2538x64CONHOST.EXEWin11 21H2UnsignedWinbindex
a26a1ffb81a6…10.0.19041.2546x64CONHOST.EXEWin10 20H2, Win10 22H2UnsignedWinbindex
3fa5c076027f…10.0.18362.2212x64CONHOST.EXEWin10 1909UnsignedWinbindex
51bb5aeef2e4…10.0.19041.1288x64CONHOST.EXEWin10 2004, Win10 21H2Signed (Catalog file)Winbindex
046f7a1b4de6…10.0.14393.0x64CONHOST.EXEWin10 1607UnsignedWinbindex
57d9d2aba477…10.0.10586.0x64CONHOST.EXEWin10 1511UnsignedWinbindex
17009e5be64b…10.0.10240.16384x64CONHOST.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.