Library / LOLBin

cscript.exe

Microsoft ® Console Based Script Host · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 78

OriginalFilename

  • cscript.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\cscript.exe'
    - OriginalFileName: 'cscript.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
cscript.exe35x64, x865.812.10240.16384 → 10.0.28000.3231Win10 1507 → Win11 26H1 (20)Host scan, Winbindex✓ 2

InternalName: cscript.exe · Product: Microsoft ® Windows Script Host

All 35 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c30faa84b6c3…10.0.28000.3231x64cscript.exeWin11 26H1Winbindex
772226f39c7e…10.0.28000.3231x86cscript.exeWin11 26H1UnsignedWinbindex
b0f9c78c7cf9…10.0.26100.9711x64cscript.exeWin11 24H2UnsignedHost scan, Winbindex✓
0cc4310c37be…10.0.26100.9711x86cscript.exeWin11 24H2UnsignedHost scan, Winbindex✓
80548d7885ec…10.0.22621.7649x86cscript.exeWin11 23H2UnsignedWinbindex
d84f0894d9e6…5.812.10240.16384x64cscript.exeWin10 1809UnsignedWinbindex
cdd8bc1367da…5.812.10240.16384x86cscript.exeWin10 21H2UnsignedWinbindex
c795a65e9244…5.812.10240.16384x64cscript.exeWin10 1607UnsignedWinbindex
bb092bc4e43e…5.812.10240.16384x86cscript.exeWin10 1809UnsignedWinbindex
7558580f6626…5.812.10240.16384x86cscript.exeWin10 1607UnsignedWinbindex
6f15c80751ab…5.812.10240.16384x64cscript.exeWin10 21H2UnsignedWinbindex
71864a482441…5.812.10240.16384x64cscript.exeWin10 21H2, Win10 22H2UnsignedWinbindex
5e340e4e2a28…5.812.10240.16384x86cscript.exeWin10 21H2, Win10 22H2UnsignedWinbindex
79dcdb0af138…5.812.10240.20973x86cscript.exeWin10 1507UnsignedWinbindex
0bb5fada9ed4…5.812.10240.20973x64cscript.exeWin10 1507UnsignedWinbindex
74ddc6e4ca76…10.0.26100.5074x64cscript.exeWin11 24H2, Win11 25H2UnsignedWinbindex
0f5bf03fae4c…10.0.26100.5074x86cscript.exeWin11 24H2, Win11 25H2UnsignedWinbindex
e69c1bdd1e4b…5.812.10240.16384x64cscript.exeWin11 22H2, Win11 23H2UnsignedWinbindex
786089e8557e…5.812.10240.16384x86cscript.exeWin11 22H2, Win11 23H2UnsignedWinbindex
bfcee871b4fb…5.812.10240.16384x86cscript.exeWin11 21H2UnsignedWinbindex
aa837e6717db…5.812.10240.16384x64cscript.exeWin11 21H2UnsignedWinbindex
b6c61c065f8b…5.812.10240.16384x86cscript.exeWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
ae37fd1b642e…5.812.10240.16384x64cscript.exeWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
d8c325e993b6…5.812.10240.16384x86cscript.exeWin10 1903, Win10 1909Signed (Catalog file)Winbindex
4f059ac07f90…5.812.10240.16384x64cscript.exeWin10 1903, Win10 1909Signed (Catalog file)Winbindex
c69648b049e3…5.812.10240.16384x64cscript.exeWin10 2004 … Win10 21H1 (3)Signed (Catalog file)Winbindex
a80e2d4b10e5…5.812.10240.16384x86cscript.exeWin10 2004 … Win10 21H1 (3)Signed (Catalog file)Winbindex
10ecc451723e…5.812.10240.16384x86cscript.exeWin10 1803UnsignedWinbindex
0e54a952cd1c…5.812.10240.16384x64cscript.exeWin10 1803UnsignedWinbindex
3355e22c8468…5.812.10240.16384x86cscript.exeWin10 1703UnsignedWinbindex
330d6e61f1c2…5.812.10240.16384x64cscript.exeWin10 1703UnsignedWinbindex
e39b2d570d79…5.812.10240.16384x64cscript.exeWin10 1709UnsignedWinbindex
d5d87ea6b12e…5.812.10240.16384x86cscript.exeWin10 1709UnsignedWinbindex
89c4963f8006…5.812.10586.1295x64cscript.exeWin10 1511UnsignedWinbindex
5b6d9ea24176…5.812.10586.1295x86cscript.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.