Library / Windows

csrss.exe

Client Server Runtime Process · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 6

OriginalFilename

  • CSRSS.Exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\csrss.exe'
    - OriginalFileName: 'CSRSS.Exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CSRSS.Exe6x6410.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (11)Host scan, Winbindex✓ 1

InternalName: CSRSS.Exe · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 9 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
dc28ba9a162a…10.0.28000.1896x64CSRSS.ExeWin11 26H1Signed (Overlay)Winbindex
d896480bc852…10.0.14393.2969x64CSRSS.ExeWin10 1607Signed (Overlay)Winbindex
a958083fd498…10.0.26100.1x64CSRSS.ExeWin11 24H2, Win11 25H2Signed (Overlay)Host scan, Winbindex✓
6f1c9b4c1876…10.0.19041.546x64CSRSS.ExeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
e10afc1f3f27…10.0.10586.0x64CSRSS.ExeWin10 1511Signed (Overlay)Winbindex
ef42c83814bd…10.0.10240.16384x64CSRSS.ExeWin10 1507Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.