Library / Windows

custominstallexec.exe

Microsoft Store Package Dependency Installer · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • CUSTOMINSTALLEXEC.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\custominstallexec.exe'
    - OriginalFileName: 'CUSTOMINSTALLEXEC.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CUSTOMINSTALLEXEC.EXE1x6410.0.26100.9711Host scan✓ 1

InternalName: CUSTOMINSTALLEXEC.EXE · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
38361562e52d…10.0.26100.9711x64CUSTOMINSTALLEXEC.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.