Library / LOLBin

customshellhost.exe

CustomShellHost · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • CustomShellHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\customshellhost.exe'
    - OriginalFileName: 'CustomShellHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
CustomShellHost.exe12x6410.0.17763.9376 → 10.0.28000.3086Win10 1809 → Win11 26H1 (13)Host scan, Winbindex✓ 1

InternalName: CustomShellHost · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 1 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d066f1ccc0b0…10.0.26100.9711x64CustomShellHost.exeWin11 24H2UnsignedHost scan, Winbindex✓
7db031e345b5…10.0.17763.9376x64CustomShellHost.exeWin10 1809UnsignedWinbindex
d292b7d864d0…10.0.28000.3086x64CustomShellHost.exeWin11 26H1UnsignedWinbindex
d8ce2f8f461a…10.0.19041.7548x64CustomShellHost.exeWin10 21H2UnsignedWinbindex
b1917deb8b3b…10.0.19041.6392x64CustomShellHost.exeWin10 21H2, Win10 22H2UnsignedWinbindex
23832d7a6e85…10.0.22621.5983x64CustomShellHost.exeWin11 22H2, Win11 23H2UnsignedWinbindex
8dd2104593f9…10.0.26100.5074x64CustomShellHost.exeWin11 24H2, Win11 25H2UnsignedWinbindex
4eeb4c841992…10.0.22000.2482x64CustomShellHost.exeWin11 21H2UnsignedWinbindex
85310c09439e…10.0.19041.2913x64CustomShellHost.exeWin10 20H2, Win10 22H2UnsignedWinbindex
eec698cad03d…10.0.18362.1766x64CustomShellHost.exeWin10 1909UnsignedWinbindex
20033667367c…10.0.19041.1387x64CustomShellHost.exeWin10 2004, Win10 20H2UnsignedWinbindex
3df826c4524e…10.0.18362.1171x64CustomShellHost.exeWin10 1903UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.