Library / Windows

dashost.exe

Device Association Framework Provider Host · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • dasHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dashost.exe'
    - OriginalFileName: 'dasHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dasHost.exe10x6410.0.10240.20708 → 10.0.28000.3231Win10 1507 → Win11 26H1 (10)Host scan, Winbindex✓ 1

InternalName: dasHost.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 10 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
45b6feb269c4…10.0.28000.3231x64dasHost.exeWin11 26H1UnsignedWinbindex
af34745a5b5a…10.0.26100.9711x64dasHost.exeWin11 24H2UnsignedHost scan, Winbindex✓
a60541a2f9a7…10.0.19041.7802x64dasHost.exeWin10 21H2UnsignedWinbindex
57a17e2faea0…10.0.17763.9376x64dasHost.exeWin10 1809UnsignedWinbindex
e9b89965e6e7…10.0.14393.9611x64dasHost.exeWin10 1607UnsignedWinbindex
afd0bd1673bf…10.0.10240.20708x64dasHost.exeWin10 1507UnsignedWinbindex
0bec0db48766…10.0.26100.5074x64dasHost.exeWin11 24H2, Win11 25H2UnsignedWinbindex
8d6881e9bfba…10.0.17134.1x64dasHost.exeWin10 1803UnsignedWinbindex
59d5bf3f8474…10.0.10586.0x64dasHost.exeWin10 1511UnsignedWinbindex
f391b3f442a5…10.0.15063.0x64dasHost.exeWin10 1703UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.