Library / Windows

defrag.exe

Disk Defragmenter Module · Microsoft Corp.

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Defrag.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\defrag.exe'
    - OriginalFileName: 'Defrag.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Defrag.EXE12x6410.0.10240.18818 → 10.0.28000.3086Win10 1507 → Win11 26H1 (16)Host scan, Winbindex✓ 1

InternalName: Defrag.EXE · Product: Windows Drive Optimizer

All 12 parsed builds · 4 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d255d9ce3a93…10.0.28000.3086x64Defrag.EXEWin11 26H1UnsignedWinbindex
29f2edf4d25f…10.0.26100.8972x64Defrag.EXEWin11 24H2UnsignedHost scan, Winbindex✓
41df106bcfda…10.0.17763.1697x64Defrag.EXEWin10 1809Signed (Catalog file)Winbindex
0744ed1b1fc3…10.0.14393.4169x64Defrag.EXEWin10 1607UnsignedWinbindex
150255e7099e…10.0.26100.5074x64Defrag.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
3c185256007c…10.0.10240.18818x64Defrag.EXEWin10 1507UnsignedWinbindex
7a18dbbe6ca1…10.0.19041.746x64Defrag.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
b21fd775352b…10.0.17134.1967x64Defrag.EXEWin10 1803UnsignedWinbindex
2630901b1b24…10.0.18362.657x64Defrag.EXEWin10 1903UnsignedWinbindex
59d6aece300e…10.0.15063.2283x64Defrag.EXEWin10 1703UnsignedWinbindex
b3bbb01c8c20…10.0.16299.1685x64Defrag.EXEWin10 1709UnsignedWinbindex
ecf0b29541c2…10.0.10586.0x64Defrag.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.