Library / LOLBin

devicecredentialdeployment.exe

"DeviceCredentialDeployment.exe" · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • "DeviceCredentialDeployment.exe"

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: devicecredentialdeployment.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\devicecredentialdeployment.exe'
    - OriginalFileName: '"DeviceCredentialDeployment.exe"'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
"DeviceCredentialDeployment.exe"8x6410.0.15063.413 → 10.0.28000.2804Win10 1703 → Win11 26H1 (12)Host scan, Winbindex✓ 1

InternalName: "DeviceCredentialDeployment.exe" · Product: Microsoft® Windows® Operating System

All 8 parsed builds · 5 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ba8c0df2f4c5…10.0.28000.2804x64"DeviceCredentialDeployment.exe"Win11 26H1Winbindex
6613b627fe4a…10.0.26100.9278x64"DeviceCredentialDeployment.exe"Win11 24H2UnsignedHost scan, Winbindex✓
d83f3245d654…10.0.17763.1697x64"DeviceCredentialDeployment.exe"Win10 1809Signed (Catalog file)Winbindex
3539cb628825…10.0.26100.1150x64"DeviceCredentialDeployment.exe"Win11 24H2, Win11 25H2Signed (Catalog file)Winbindex
eaa357686ca4…10.0.22000.653x64"DeviceCredentialDeployment.exe"Win11 21H2UnsignedWinbindex
84d481ae5efe…10.0.19041.746x64"DeviceCredentialDeployment.exe"Win10 2004 … Win10 22H2 (5)UnsignedWinbindex
106f6ddac537…10.0.17134.1967x64"DeviceCredentialDeployment.exe"Win10 1803UnsignedWinbindex
433e59f6c1f4…10.0.15063.413x64"DeviceCredentialDeployment.exe"Win10 1703UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.