Library / Windows

deviceenroller.exe

API for MDM Enrollment · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • deviceenroller.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\deviceenroller.exe'
    - OriginalFileName: 'deviceenroller.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
deviceenroller.exe19x6410.0.10240.18818 → 10.0.28000.3086Win10 1507 → Win11 26H1 (19)Host scan, Winbindex✓ 1

InternalName: API for MDM Enrollment · Product: Microsoft® Windows® Operating System

All 19 parsed builds · 1 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
7059af5b0c07…10.0.28000.3086x64deviceenroller.exeWin11 26H1UnsignedWinbindex
e6a132b0fe16…10.0.26100.9711x64deviceenroller.exeWin11 24H2UnsignedHost scan, Winbindex✓
cae021bca12a…10.0.22621.7649x64deviceenroller.exeWin11 23H2UnsignedWinbindex
f75515400157…10.0.17763.9376x64deviceenroller.exeWin10 1809UnsignedWinbindex
d57dad136d81…10.0.14393.7426x64deviceenroller.exeWin10 1607UnsignedWinbindex
7ad39c83c805…10.0.19041.7548x64deviceenroller.exeWin10 21H2UnsignedWinbindex
b0e09938bb25…10.0.19041.6157x64deviceenroller.exeWin10 21H2, Win10 22H2UnsignedWinbindex
a530f204c4f2…10.0.10240.18818x64deviceenroller.exeWin10 1507UnsignedWinbindex
bcec84760c0b…10.0.26100.5074x64deviceenroller.exeWin11 24H2, Win11 25H2UnsignedWinbindex
2c52555da683…10.0.22000.2960x64deviceenroller.exeWin11 21H2UnsignedWinbindex
3eb15421375c…10.0.19041.2913x64deviceenroller.exeWin10 20H2, Win10 22H2UnsignedWinbindex
50a76448dfdb…10.0.18362.1766x64deviceenroller.exeWin10 1909UnsignedWinbindex
8665d3698c2b…10.0.19041.1081x64deviceenroller.exeWin10 2004UnsignedWinbindex
06f7b0c17988…10.0.19041.906x64deviceenroller.exeWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
6563facd02c4…10.0.17134.1967x64deviceenroller.exeWin10 1803UnsignedWinbindex
3643abef0f41…10.0.18362.1237x64deviceenroller.exeWin10 1903UnsignedWinbindex
8468f04aad27…10.0.15063.1058x64deviceenroller.exeWin10 1703UnsignedWinbindex
156025500d39…10.0.16299.1237x64deviceenroller.exeWin10 1709UnsignedWinbindex
1c8bdf6631f9…10.0.10586.420x64deviceenroller.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.