Library / Windows

deviceproperties.exe

Device Properties · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • DeviceProperties.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\deviceproperties.exe'
    - OriginalFileName: 'DeviceProperties.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
DeviceProperties.exe1x6410.0.26100.1Host scan✓ 1

InternalName: DeviceProperties · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
59c4bd37da9c…10.0.26100.1x64DeviceProperties.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.