Library / Windows

dfrgui.exe

Microsoft® Drive Optimizer · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • lhdfrgui.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: dfrgui.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dfrgui.exe'
    - OriginalFileName: 'lhdfrgui.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
lhdfrgui.exe2x64, x8610.0.26100.8972Host scan✓ 2

InternalName: lhdfrgui.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fb229970fedc…10.0.26100.8972x64lhdfrgui.exeHost scan✓
97d677bd8db7…10.0.26100.8972x86lhdfrgui.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.