Library / LOLBin

dfshim.dll

ClickOnce Application Deployment Support Library · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • dfshim.dll

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dfshim.dll'
    - OriginalFileName: 'dfshim.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dfshim.dll13x64, x8610.0.10240.19444 → 10.0.28000.2605Win10 1507 → Win11 26H1 (8)Winbindex

InternalName: dfshim.dll · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 25 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
011410f6ff0b…10.0.28000.2605x64dfshim.dllWin11 26H1Winbindex
514ab979cd10…10.0.28000.1643x86dfshim.dllWin11 26H1UnsignedWinbindex
8481c9d7c92e…10.0.26100.1882x86dfshim.dllWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
5cde036cc65a…10.0.26100.1882x64dfshim.dllWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
9f6b743c76d8…10.0.17763.3406x64dfshim.dllWin10 1809UnsignedWinbindex
9673de9c6091…10.0.17763.3406x86dfshim.dllWin10 1809UnsignedWinbindex
aa3e5988386d…10.0.14393.5356x86dfshim.dllWin10 1607UnsignedWinbindex
79b0052cff90…10.0.14393.5356x64dfshim.dllWin10 1607UnsignedWinbindex
a6437fd12f77…10.0.10240.19444x64dfshim.dllWin10 1507UnsignedWinbindex
9b7ea53bb3aa…10.0.10240.19444x86dfshim.dllWin10 1507UnsignedWinbindex
3ef622c57f22…10.0.17134.1x64dfshim.dllWin10 1803UnsignedWinbindex
d176d3fe252d…10.0.10586.0x86dfshim.dllWin10 1511UnsignedWinbindex
521efe3ccd62…10.0.10586.0x64dfshim.dllWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.