Library / Sysinternals

diskmon.exe

Disk Monitor · Sysinternals

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Diskmon.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as diskmon64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\diskmon.exe'
    - OriginalFileName: 'Diskmon.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Diskmon.exe1x862.0.2.0Sysinternals✓ 1

InternalName: Diskmon · Product: Sysinternals Diskmon

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b9b8d53e1c52…2.0.2.0x86Diskmon.exeSysinternals DiskmonSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.