Library / Windows

diskpart.exe

DiskPart · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • diskpart.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\diskpart.exe'
    - OriginalFileName: 'diskpart.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
diskpart.exe2x64, x8610.0.26100.1 → 10.0.26100.1150Host scan✓ 2

InternalName: diskpart.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a9882c2c1992…10.0.26100.1150x64diskpart.exeHost scan✓
fc9d12a26ffb…10.0.26100.1x86diskpart.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.