Library / Windows

diskperf.exe

Disk Performance Configuration Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • DISKPERF.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\diskperf.exe'
    - OriginalFileName: 'DISKPERF.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
DISKPERF.EXE2x64, x8610.0.26100.9711Host scan✓ 2

InternalName: DISKPERF.EXE · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
65514dc60577…10.0.26100.9711x64DISKPERF.EXEHost scan✓
17bae5ae9b4f…10.0.26100.9711x86DISKPERF.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.