Library / Windows

dispdiag.exe

Display Diagnostics · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • dispdiag.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dispdiag.exe'
    - OriginalFileName: 'dispdiag.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dispdiag.exe1x6410.0.26100.9549Host scan✓ 1

InternalName: dispdiag.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0129ab3ad337…10.0.26100.9549x64dispdiag.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.