Library / Windows

dllhost.exe

COM Surrogate · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 18

OriginalFilename

  • dllhost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dllhost.exe'
    - OriginalFileName: 'dllhost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dllhost.exe15x64, x8610.0.10240.16384 → 10.0.28000.3086Win10 1507 → Win11 26H1 (12)Host scan, Winbindex✓ 2

InternalName: dllhost.exe · Product: Microsoft® Windows® Operating System

All 15 parsed builds · 17 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f1e28e38fe3c…10.0.28000.3086x86dllhost.exeWin11 26H1Signed (Overlay)Winbindex
4448086368fa…10.0.28000.3086x64dllhost.exeWin11 26H1Signed (Overlay)Winbindex
abee3c2607c2…10.0.26100.9549x64dllhost.exeWin11 24H2Signed (Overlay)Host scan, Winbindex✓
215233077d87…10.0.26100.9549x86dllhost.exeWin11 24H2Signed (Overlay)Host scan, Winbindex✓
50c9c2edea6c…10.0.26100.1150x64dllhost.exeWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
d5181106f825…10.0.26100.1x86dllhost.exeWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
e7fc40b41aa8…10.0.19041.546x64dllhost.exeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
3ed69caab035…10.0.19041.546x86dllhost.exeWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
204fd3da29e9…10.0.17134.1x64dllhost.exeWin10 1803Signed (Overlay)Winbindex
ee8364c07b3f…10.0.14393.0x64dllhost.exeWin10 1607Signed (Overlay)Winbindex
5137c324038a…10.0.14393.0x86dllhost.exeWin10 1607Signed (Overlay)Winbindex
f91760ed5de4…10.0.10586.0x86dllhost.exeWin10 1511Signed (Overlay)Winbindex
da2a486f7449…10.0.10586.0x64dllhost.exeWin10 1511Signed (Overlay)Winbindex
d17414e03a59…10.0.10240.16384x86dllhost.exeWin10 1507Signed (Overlay)Winbindex
7f5e20d3a1b0…10.0.10240.16384x64dllhost.exeWin10 1507Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.