Library / Windows

dllhst3g.exe

COM Surrogate · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • dllhst3g.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dllhst3g.exe'
    - OriginalFileName: 'dllhst3g.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dllhst3g.exe11x64, x8610.0.10240.16384 → 10.0.26100.9549Win10 1507 → Win11 25H2 (6)Host scan, Winbindex✓ 2

InternalName: dllhst3g.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 27 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d372bfc5506b…10.0.26100.9549x86dllhst3g.exeWin11 24H2UnsignedHost scan, Winbindex✓
2e39f126213e…10.0.26100.9549x64dllhst3g.exeWin11 24H2UnsignedHost scan, Winbindex✓
a25ab27eb83a…10.0.26100.1150x64dllhst3g.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
c93184ebb233…10.0.26100.1x86dllhst3g.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
9bb56bdb7127…10.0.17134.1x64dllhst3g.exeWin10 1803UnsignedWinbindex
b9c234164a34…10.0.14393.0x64dllhst3g.exeWin10 1607UnsignedWinbindex
a56a69cb90ea…10.0.14393.0x86dllhst3g.exeWin10 1607UnsignedWinbindex
dd18b7b6a45e…10.0.10586.0x86dllhst3g.exeWin10 1511UnsignedWinbindex
180554911e76…10.0.10586.0x64dllhst3g.exeWin10 1511UnsignedWinbindex
f2d5a7a46f7e…10.0.10240.16384x64dllhst3g.exeWin10 1507UnsignedWinbindex
56f0d5ce7c6e…10.0.10240.16384x86dllhst3g.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.