Library / Windows

dnscacheugc.exe

DNSCache Unattend Generic Command · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • dnscacheugc.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dnscacheugc.exe'
    - OriginalFileName: 'dnscacheugc.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dnscacheugc.exe1x6410.0.26100.8521Host scan✓ 1

InternalName: dnscacheugc.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
95133819c8de…10.0.26100.8521x64dnscacheugc.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.