Library / LOLBin

dnscmd.exe

DNS Command Line Admin Utility · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 3

OriginalFilename

  • dnscmd.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dnscmd.exe'
    - OriginalFileName: 'dnscmd.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dnscmd.exe11x6410.0.10586.589 → 10.0.28000.3231Win10 1511 → Win11 26H1 (11)Winbindex

InternalName: dnscmd.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 5 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b114431bf7f4…10.0.28000.3231x64dnscmd.exeWin11 26H1Winbindex
2710ca68c609…10.0.26100.9711x64dnscmd.exeWin11 24H2UnsignedWinbindex
74abf6fddd90…10.0.14393.9611x64dnscmd.exeWin10 1607UnsignedWinbindex
834507fdf36e…10.0.17763.9245x64dnscmd.exeWin10 1809UnsignedWinbindex
2d7b60b1982d…10.0.19041.1645x64dnscmd.exeWin10 20H2UnsignedWinbindex
5d47f5a4f78c…10.0.18362.1440x64dnscmd.exeWin10 1909UnsignedWinbindex
06cea1faf952…10.0.19041.867x64dnscmd.exeWin10 2004UnsignedWinbindex
75af2df2ba41…10.0.18362.1082x64dnscmd.exeWin10 1903, Win10 1909UnsignedWinbindex
28c7f30f9fce…10.0.16299.1059x64dnscmd.exeWin10 1709UnsignedWinbindex
b8446add42f9…10.0.17134.753x64dnscmd.exeWin10 1803UnsignedWinbindex
16d21c3ae37c…10.0.10586.589x64dnscmd.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.