Library / LOLBin

dotnet.exe

.NET Host · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 2

OriginalFilename

  • .NET Host

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: dotnet.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dotnet.exe'
    - OriginalFileName: '.NET Host'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
.NET Host1x649.0.2226.52218Host scan

InternalName: .NET Host · Product: .NET

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c16771e66023…9.0.2226.52218x64.NET HostHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.