Library / Windows

driverquery.exe

Queries the drivers on a system · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • drvqry.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: driverquery.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\driverquery.exe'
    - OriginalFileName: 'drvqry.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
drvqry.exe4x64, x8610.0.22000.653 → 10.0.26100.4202Win11 21H2Host scan, Winbindex✓ 2

InternalName: driverquery.exe · Product: Microsoft® Windows® Operating System

All 4 parsed builds · 36 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6723abdd517f…10.0.22000.653x64drvqry.exeWin11 21H2UnsignedWinbindex
3446ffc8d1d6…10.0.22000.653x86drvqry.exeWin11 21H2UnsignedWinbindex
ec380b8c0f94…10.0.26100.4202x86drvqry.exeHost scan✓
84b5a5ebdc2c…10.0.26100.4202x64drvqry.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.