Library / Windows

drvinst.exe

Driver Installation Module · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • DrvInst.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\drvinst.exe'
    - OriginalFileName: 'DrvInst.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
DrvInst.EXE1x6410.0.26100.9711Host scan✓ 1

InternalName: DrvInst.EXE · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f517e2e20eb4…10.0.26100.9711x64DrvInst.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.