Library / LOLBin

dsdbutil.exe

NT5DS · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • dsDbUtil.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dsdbutil.exe'
    - OriginalFileName: 'dsDbUtil.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dsDbUtil.exe13x64, x8610.0.10240.19685 → 10.0.28000.2605Win10 1507 → Win11 26H1 (8)Winbindex

InternalName: dsDbUtil.exe · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fa38a1bf33b5…10.0.28000.2605x64dsDbUtil.exeWin11 26H1UnsignedWinbindex
a792f658b6f7…10.0.28000.2336x86dsDbUtil.exeWin11 26H1UnsignedWinbindex
9b108ec20871…10.0.26100.8521x64dsDbUtil.exeWin11 24H2UnsignedWinbindex
42ab3de16b28…10.0.26100.8521x86dsDbUtil.exeWin11 24H2UnsignedWinbindex
13ee2c10e03f…10.0.14393.5648x86dsDbUtil.exeWin10 1607UnsignedWinbindex
094c9dc06871…10.0.14393.5648x64dsDbUtil.exeWin10 1607UnsignedWinbindex
8957563aeb54…10.0.10240.19685x64dsDbUtil.exeWin10 1507UnsignedWinbindex
0839cb38a86f…10.0.10240.19685x86dsDbUtil.exeWin10 1507UnsignedWinbindex
82e3151f144b…10.0.19041.2486x64dsDbUtil.exeWin10 20H2UnsignedWinbindex
f324fe1732d4…10.0.19041.844x64dsDbUtil.exeWin10 2004, Win10 20H2UnsignedWinbindex
c5b77517bff3…10.0.19041.844x86dsDbUtil.exeWin10 2004, Win10 20H2UnsignedWinbindex
ade966d0aac5…10.0.18362.628x64dsDbUtil.exeWin10 1903, Win10 1909UnsignedWinbindex
3da7b61dd7b3…10.0.18362.628x86dsDbUtil.exeWin10 1903, Win10 1909UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.