Library / Windows

dsmusertask.exe

Device Setup Manager User Task Handler · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • DsmUserTask.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dsmusertask.exe'
    - OriginalFileName: 'DsmUserTask.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
DsmUserTask.exe1x6410.0.26100.4202Host scan✓ 1

InternalName: DsmUserTask.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4ca522be6a9e…10.0.26100.4202x64DsmUserTask.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.