Library / Windows

dsquery.exe

Microsoft AD DS/LDS query command line utility · Microsoft Corporation

WindowsParsedSigma refs: 3

OriginalFilename

  • dsquery.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\dsquery.exe'
    - OriginalFileName: 'dsquery.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
dsquery.exe3x64, x8610.0.26100.7920 → 10.0.28000.1896Win11 24H2 → Win11 26H1 (2)Winbindex

InternalName: dsquery.exe · Product: Microsoft® Windows® Operating System

All 3 parsed builds · 1 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6e3f34696fc7…10.0.28000.1896x86dsquery.exeWin11 26H1Winbindex
5ffe4464a647…10.0.28000.1896x64dsquery.exeWin11 26H1Winbindex
11f7f1e8e0d3…10.0.26100.7920x64dsquery.exeWin11 24H2UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.